POJ 2346 Lucky tickets(数位dp求前几位数字和)

Lucky tickets
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 3376
Accepted: 2235

Description

The public transport administration of Ekaterinburg is anxious about the fact that passengers don't like to pay for passage doing their best to avoid the fee. All the measures that had been taken (hard currency premiums for all of the chiefs, increase in conductors' salaries, reduction of number of buses) were in vain. An advisor especially invited from the Ural State University says that personally he doesn't buy tickets because he rarely comes across the lucky ones (a ticket is lucky if the sum of the first three digits in its number equals to the sum of the last three ones). So, the way out is found — of course, tickets must be numbered in sequence, but the number of digits on a ticket may be changed. Say, if there were only two digits, there would have been ten lucky tickets (with numbers 00, 11, ..., 99). Maybe under the circumstances the ratio of the lucky tickets to the common ones is greater? And what if we take four digits? A huge work has brought the long-awaited result: in this case there will be 670 lucky tickets. But what to do if there are six or more digits? 
So you are to save public transport of our city. Write a program that determines a number of lucky tickets for the given number of digits. By the way, there can't be more than 10 digits on one ticket.

Input

Input contains a positive even integer N not greater than 10. It's an amount of digits in a ticket number.

Output

Output should contain a number of tickets such that the sum of the first N/2 digits is equal to the sum of the second half of digits.

Sample Input

4

Sample Output

670

Source

题目大意:给定一个n,求n位数中有多少个数的前n/2位的和与后n/2位的和相等. 
解题思路:
就是求n/2位数有多少种不同的和
1、dp[ i ][ j ]表示为第 i 位和为 j 的数有多少
2、ans为dp[ n/2 ][ 0 ~ n/2*9 ]平方和
AC代码
#include<cstdio>
#include<iostream>
using namespace std;
int dp[6][50];
void init(){
	dp[0][0]=1;
	for(int i=1;i<=5;i++){
		for(int j=0;j<=i*9;j++){
			for(int k=0;k<=9;k++){
				if(j>=k)dp[i][j]+=dp[i-1][j-k];
			}
		}
	}
}
int main(){
	init();
	int n;
	scanf("%d",&n);
	int sum=0;
	for(int i=0;i<=n/2*9;i++){
		sum+=dp[n/2][i]*dp[n/2][i];
	}
	printf("%d\n",sum);
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值