搜索 T题

 
Description
Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1. 

Input

The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.

Output

For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.

Sample Input

3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1

Sample Output

5
28
0
2.解题思路:
  题意:马走棋盘,从一点走到另一点,至少要走多少步。
  用深搜求最短路径。用队列储存每次向八个方向的移动的点,每次从对头取点,然后到达要求的点即为最短步数。
3.代码:
#include <iostream>
#include <string.h>
#include <queue>
#include <algorithm>
#include <queue>
#include <stdio.h>
using namespace std;
int n,sx,sy,ex,ey;
int visit[305][305];
int to[8][2] = {-1,-2,-2,-1,-2,1,-1,2,1,-2,2,-1,2,1,1,2};
struct node
{
    int x,y,step;
};


int c(int x,int y)
{
    if(x<0 || x>=n || y<0 || y>=n)
    return 1;
    return visit[x][y];
}


void bfs()
{
    memset(visit,0,sizeof(visit));
    node a,next;
    queue<node> q;
    int i;
    a.x = sx;
    a.y = sy;
    a.step = 0;
    visit[sx][sy] = 1;
    q.push(a);
    while(!q.empty())
    {
        a = q.front();
        q.pop();
        if(a.x == ex && a.y == ey)
        {
            printf("%d\n",a.step);
            return;
        }
        for(i = 0;i<8;i++)
        {
            next = a;
            next.x = a.x+to[i][0];
            next.y = a.y+to[i][1];
            if(c(next.x,next.y))
            continue;
            next.step = a.step+1;
            visit[next.x][next.y] = 1;
            q.push(next);
        }
    }
}


int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d%d",&n,&sx,&sy,&ex,&ey);
        bfs();
    }


    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值