Equations
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 7730 Accepted Submission(s): 3177
Problem Description
Consider equations having the following form:
a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.
It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.
Determine how many solutions satisfy the given equation.
a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.
It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.
Determine how many solutions satisfy the given equation.
Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
End of file.
Output
For each test case, output a single line containing the number of the solutions.
Sample Input
1 2 3 -4 1 1 1 1
Sample Output
39088 0
Author
LL
这题很考验思维,如果直接暴力的话妥妥的超时
观察题目未知数都是平方所以正负判断一种情况就好最后结果*16,再讲时间复杂度降低利用数组将出现过的值用下标标记四重循环降低为两重循环正负值一一对应,最后要注意0也要一一对应
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <sstream>
#include <set>
#include <map>
#include <cmath>
#include <malloc.h>
#include <algorithm>
using namespace std;
const int N = 1000010;
int hash1[N], hash2[N];
int main()
{
int a,b,c,d;
while(scanf("%d %d %d %d",&a, &b, &c, &d)!=EOF)
{
if((a>0&&b>0&&c>0&&d>0)||(a<0&&b<0&&c<0&&d<0))
{
printf("0\n");
continue;
}
memset(hash1,0,sizeof(hash1));
memset(hash2,0,sizeof(hash2));
for(int i=1;i<=100;i++)
{
for(int j=1;j<=100;j++)
{
int s=a*i*i+b*j*j;
if(s>=0)
{
hash1[s]++;
}
else
{
hash2[-s]++;
}
}
}
int ans=0;
for(int i=1;i<=100;i++)
{
for(int j=1;j<=100;j++)
{
int s=c*i*i+d*j*j;
if(s>0)
{
ans+=hash2[s];
}
else
{
ans+=hash1[-s];
}
}
}
printf("%d\n",ans*16);
}
return 0;
}