hdu 3836 Equivalent Sets (强连通分量 缩点)@



To prove two sets A and B are equivalent, we can first prove A is a subset of B, and then prove B is a subset of A, so finally we got that these two sets are equivalent.
You are to prove N sets are equivalent, using the method above: in each step you can prove a set X is a subset of another set Y, and there are also some sets that are already proven to be subsets of some other sets. 
Now you want to know the minimum steps needed to get the problem proved.
Input
The input file contains multiple test cases, in each case, the first line contains two integers N <= 20000 and M <= 50000. 
Next M lines, each line contains two integers X, Y, means set X in a subset of set Y.
Output
For each case, output a single integer: the minimum steps needed.
Sample Input
4 0
3 2
1 2
1 3
Sample Output
4
2

        
  
Hint
  
  
Case 2: First prove set 2 is a subset of set 1 and then prove set 3 is a subset of set 1.


题目大意:x是y的子集,y是x的子集,则x=y,给n个子集和m个子集关系,问要证明他们都相等还需要多少步,其实本质就是求让这些点形成一个环需要
的步数;给定一张有向图,求加多少条边之后整个图是一张强连通分量。思路大致是:先将图中的强连通分量缩点,使得图变成一张无环图,这个时
候图上剩余k1个出度为0的点和k2个入度为0的点,将出度为0的点连一条有向边到入度为0的点,此时形成一个环,这个环是一个强连通分量,可以再
缩成一个点,当图中只剩一个点的时候,就完成了任务。显而易见的是最大只要连接max{k1,k2}条边,就能将所有的点缩成一个点。



 
 
 
 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <vector>
using namespace std;
const int N = 1e5+10;
int cnt, taj, top, time;
int vis[N], head[N], stack1[N], low[N], dfn[N], belong[N];
void init()
{
    memset(vis,0,sizeof(vis));
    memset(head,-1,sizeof(head));
    memset(low,-1,sizeof(low));
    memset(dfn,-1,sizeof(dfn));
    cnt=0, top=0, taj=0, time=0;
    return ;
}

struct node
{
    int from, to, next;
}p[N];

void add(int u,int v)
{
   p[cnt].from=u, p[cnt].to=v, p[cnt].next=head[u], head[u]=cnt++;
   return ;
}

void dfs(int u)
{
    low[u]=time;
    dfn[u]=time++;
    vis[u]=1, stack1[top++]=u;
    for(int i=head[u];i!=-1;i=p[i].next)
    {
        int v=p[i].to;
        if(dfn[v]==-1)
        {
            dfs(v);
            low[u]=min(low[u], low[v]);
        }
        else if(vis[v])
             low[u]=min(low[u], dfn[v]);
    }
    if(dfn[u]==low[u])
    {
        taj++;
        while(1)
        {
            int now=stack1[--top];
            vis[now]=0;
            belong[now]=taj;
            if(now==u)
                break;
        }
    }
    return ;
}
int in[N], out[N];

int main()
{
    int n, m;
    while(scanf("%d %d", &n, &m)!=EOF)
    {
        init();
        for(int i=0;i<m;i++)
        {
            int x, y;
            scanf("%d %d", &x, &y);
            add(x, y);
        }
        for(int i=1;i<=n;i++)
        {
            if(dfn[i]==-1)
                dfs(i);
        }
        if(n==0||taj==1)
        {
            printf("0\n");
            continue;
        }
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));

        for(int i=0;i<cnt;i++)
        {
            int x=p[i].from, y=p[i].to;
            if(belong[x]!=belong[y])
                out[belong[x]]++, in[belong[y]]++;
        }
        int ans1=0, ans2=0;
        for(int i=1;i<=taj;i++)
        {
            if(in[i]==0) ans1++;
            if(out[i]==0) ans2++;
        }
        printf("%d\n",max(ans1,ans2));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值