FZU 2218 Simple String Problem (状压DP解决集合不相同元素问题)

Recently, you have found your interest in string theory. Here is an interesting question about strings.

You are given a string S of length n consisting of the first k lowercase letters.

You are required to find two non-empty substrings (note that substrings must be consecutive) of S, such that the two substrings don't share any same letter. Here comes the question, what is the maximum product of the two substring lengths?

Input

The first line contains an integer T, meaning the number of the cases. 1 <= T <= 50.

For each test case, the first line consists of two integers n and k. (1 <= n <= 2000, 1 <= k <= 16).

The second line is a string of length n, consisting only the first k lowercase letters in the alphabet. For example, when k = 3, it consists of a, b, and c.

Output

For each test case, output the answer of the question.

Sample Input
4
25 5
abcdeabcdeabcdeabcdeabcde
25 5
aaaaabbbbbcccccdddddeeeee
25 5
adcbadcbedbadedcbacbcadbc
3 2
aaa
Sample Output
6
150
21
0
Hint

One possible option for the two chosen substrings for the first sample is "abc" and "de".

The two chosen substrings for the third sample are "ded" and "cbacbca".

In the fourth sample, we can't choose such two non-empty substrings, so the answer is 0.



#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <queue>
using namespace std;
typedef long long LL;
const int N = 1e5+10;
char str[N];
int dp[(1<<17)+10];


int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n, m;
        scanf("%d %d", &n, &m);
        scanf("%s",str);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            int t=0;
            for(int j=i;j<n;j++)//枚举所有集合所含元素状态的最长长度
            {
                t|=(1<<(str[j]-'a'));
                dp[t]=max(dp[t],j-i+1);
            }
        }
        for(int i=0;i<(1<<m);i++)
        {
            for(int j=0;j<m;j++)
            {
                if(i&(1<<j))
                {
                    dp[i]=max(dp[i],dp[i^(1<<j)]);//因为可能并不是所有m个元素都含有,所以子集元素可能更有,处理了用总的集合异或当前状态的集合
                }
            }
        }
        int ans=0;
        for(int i=0;i<(1<<m);i++)
        {
            ans=max(ans,dp[i]*(dp[((1<<m)-1)^i]));
        }
        printf("%d\n",ans);
    }
    return 0;
}










评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值