hdu 3613 Best Reward(exkmp)

Best Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2722    Accepted Submission(s): 1104


Problem Description
After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit. 

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.) 

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li. 

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero. 

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value. 

 

Input
The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows. 

For each test case, the first line is 26 integers: v 1, v 2, ..., v 26 (-100 ≤ v i ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind. 

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v 1, the value of 'b' is v 2, ..., and so on. The length of the string is no more than 500000. 

 

Output
Output a single Integer: the maximum value General Li can get from the necklace.
 

Sample Input
  
  
2 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 aba 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 acacac
 

Sample Output
  
  
1 6


题意:给一个字符串,分成两部分,如果分开后的字符串是回文串就加上他的价值,求分法最大价值;

解;做两次EXKMP,第一次把正序当成匹配串,逆序当成文本串,如果extend[len-i]==i就是回文串

#include <iostream>
#include <cstdio>
#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int N = 5e5+10;
const LL mod = 1e9+7;
char s1[N], s2[N];
int v[30], sum[N], extend1[N], extend2[N], nex[N];
void getnext(char a[],int len)
{
    int k=0, i=1;
    nex[0]=len;
    while(k+1<len&&a[k]==a[k+1])++k;
    nex[1]=k;
    k=1;
    while(++i<len)
    {
        int p=k+nex[k]-1;
        nex[i]=min(nex[i-k],max(p-i+1,0));
        while(i+nex[i]<len&&a[nex[i]]==a[i+nex[i]]) ++nex[i];
        if(i+nex[i]>k+nex[k]) k=i;
    }
    return ;
}


void exkmp(char a[],char b[],int extend[],int len)
{
    getnext(a,len);
    int k=0, i=0;
    while(k<len&&a[k]==b[k]) ++k;
    extend[0]=k;
    k=0;
    while(++i<len)
    {
        int p=k+extend[k]-1;
        extend[i]=min(nex[i-k],max(p-i+1,0));
        while(i+extend[i]<len&&a[extend[i]]==b[i+extend[i]]) ++extend[i];
        if(i+extend[i]>k+extend[k]) k=i;
    }
    return ;
}

int main()
{
    int t, ncase=1;
    scanf("%d", &t);
    while(t--)
    {
        for(int i=0;i<26;i++) scanf("%d", &v[i]);
        scanf("%s",s1);
        int len=strlen(s1);
        sum[0]=0;
        for(int i=1;i<=len;i++)
        {
            sum[i]=sum[i-1]+v[s1[i-1]-'a'];
            s2[i-1]=s1[len-i];
        }
        exkmp(s1,s2,extend1,len);
        exkmp(s2,s1,extend2,len);
        int ans=0;
        for(int i=1;i<len;i++)
        {
            int cnt=0;
            if(extend1[len-i]==i) cnt+=sum[i];
            if(extend2[i]==len-i) cnt+=(sum[len]-sum[i]);
            ans=max(ans,cnt);
        }
        printf("%d\n",ans);
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值