HDOJ 3613 Manacher

2 篇文章 0 订阅

Best Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3988    Accepted Submission(s): 1629


 

Problem Description

After an uphill battle, General Li won a great victory. Now the head of state decide to reward him with honor and treasures for his great exploit. 

One of these treasures is a necklace made up of 26 different kinds of gemstones, and the length of the necklace is n. (That is to say: n gemstones are stringed together to constitute this necklace, and each of these gemstones belongs to only one of the 26 kinds.) 

In accordance with the classical view, a necklace is valuable if and only if it is a palindrome - the necklace looks the same in either direction. However, the necklace we mentioned above may not a palindrome at the beginning. So the head of state decide to cut the necklace into two part, and then give both of them to General Li. 

All gemstones of the same kind has the same value (may be positive or negative because of their quality - some kinds are beautiful while some others may looks just like normal stones). A necklace that is palindrom has value equal to the sum of its gemstones' value. while a necklace that is not palindrom has value zero. 

Now the problem is: how to cut the given necklace so that the sum of the two necklaces's value is greatest. Output this value. 

 

 

 

Input

The first line of input is a single integer T (1 ≤ T ≤ 10) - the number of test cases. The description of these test cases follows. 

For each test case, the first line is 26 integers: v1, v2, ..., v26 (-100 ≤ vi ≤ 100, 1 ≤ i ≤ 26), represent the value of gemstones of each kind. 

The second line of each test case is a string made up of charactor 'a' to 'z'. representing the necklace. Different charactor representing different kinds of gemstones, and the value of 'a' is v1, the value of 'b' is v2, ..., and so on. The length of the string is no more than 500000. 

 

 

 

Output

Output a single Integer: the maximum value General Li can get from the necklace.

 

 

Sample Input

 

2

1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1

aba

1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1

acacac

 

 

Sample Output

 

1 6

 

 

Source

2010 ACM-ICPC Multi-University Training Contest(18)——Host by TJU

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  3618 3620 3614 3615 3616 

这题我们怎么想呢?

我们可以这样想 我们用Manacher建立一个数组 这样进行枚举 用前缀和优化即可 注意不能取全部

#include<cstdio>
#include<cstring>
#include<algorithm>
#include <iostream>
using namespace std;
//#define dbg(x) cout<<#x<<" = "<< (x)<< endl
const int maxl=1000000;
char to[35];
int te,p[2*maxl+5],sum[maxl<<1+5];
char s[maxl+5],now[2*maxl+5];

void readln() {scanf("%*[^\n]");getchar();}
bool Eoln(char ch) {return ch==10||ch==13||ch==EOF;}
int reads(char *x)
{
    int len=0;char ch=getchar();if (ch==EOF) return EOF;
    s[++len]=ch;while (!Eoln(s[len])) s[++len]=getchar();s[len--]=0;
    return len;
}
long long Manacher(char *s)
{
    int len=strlen(s);
    //dbg(len);
    now[0] = '@';
    for (int i=1;i<=len;i++)
    {
        //dbg(s[i-1]);
        now[2*i-1]='%',now[2*i]=s[i-1];
        //dbg(now[2*i-1]);
        //dbg(now[2*i]);
    }
    now[len=len*2+1]='%';
    now[len+1] = '$';
    now[len+2] = '\0';
    //dbg(now);
    int pos=0,R=0;
    for (int i=1;i<=len;i++)
    {
        if (i<R) p[i]=min(p[2*pos-i],R-i); else p[i]=1;
        while (1<=i-p[i]&&i+p[i]<=len&&now[i-p[i]]==now[i+p[i]]) p[i]++;
        if (i+p[i]>R) {pos=i;R=i+p[i];}
        //printf("%d\n",p[i]);
    }
     for(int i = 1;i<=len;i++){
      if(now[i]<='z'&&now[i]>='a') sum[i] = sum[i-1]+to[now[i]-'a'];
      else sum[i] = sum[i-1];
        }
    //for(int i = 1;i<=len;++i)
        //dbg(p[i]);
        //dbg(s);
    long long maxx = 0;
    long long ans ;
    //dbg(now);
    for(int i = 1;i<=len/2;i++){
     ans = 0;
     //dbg(p[i]);
     //dbg(i);
     //dbg(2*(i-1)+(len-2*(i-1)+1)/2);
    if(p[i]==i&&2*p[i]-1!=len) ans+= sum[2*(i-1)];
    //dbg(ans);
    //dbg(2*p[2*(i-1)+(len-2*(i-1)+1)/2]-1);
    //dbg(len-2*(i-1));
    if(2*p[2*(i-1)+(len-2*(i-1)+1)/2]-1==len-2*(i-1)&&i!=1) ans += sum[len]-sum[2*(i-1)];
    //dbg(sum[len]);
    //dbg(ans);
    maxx=max(maxx,ans);
      }
      return maxx;
}
int main()
{
    //freopen("Manacher.in","r",stdin);
    //freopen("Manacher.out","w",stdout);
    int t;
    scanf("%d",&t);
    //scanf("%d",&te);readln();
    while (t--) {
            for(int i= 0;i<26;++i)
            scanf("%d",&to[i]);
            scanf("%s",s);
      printf("%I64d\n",Manacher(s));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值