现在有两个长度为n的排列p和s。要求通过交换使得p变成s。交换 pi 和 pj 的代价是|i-j|。要求使用最少的代价让p变成s。
Input
单组测试数据。 第一行有一个整数n (1≤n≤200000),表示排列的长度。 第二行有n个范围是1到n的整数,表示排列p。每个整数只出现一次。 第三行有n个范围是1到n的整数,表示排列s。每个整数只出现一次。
Output
输出一个整数,表示从排列p变到s最少要多少代价。
Input示例
样例输入1 4 4 2 1 3 3 2 4 1
Output示例
样例输出1 3
将一个数的首末位置相减除以2就是答案,(从移动的本质入手 宏观的观察整个操作实质)因为每次移动两个数,贪心的选取 通过移动使两个数离目标位置都接近的 两个数,为什么一定可以找到,因为一个数不在他的目标位置上 就一定有另一个数也不在目标位置上 一个数向左移动 另一个数向右移动
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <algorithm>
#include <climits>
using namespace std;
const int N = 200000+100;
typedef long long LL;
char str[N];
int p[N], s[N], id[N], pos[N], vis[N];
int main()
{
int n;
scanf("%d", &n);
for(int i=1;i<=n;i++)
{
scanf("%d", &p[i]);
id[p[i]]=i;
}
for(int i=1;i<=n;i++)
{
scanf("%d", &s[i]);
pos[s[i]]=i;
}
LL sum=0;
for(LL i=1;i<=n;i++)
{
if(s[i]!=p[i])
{
sum+=(LL)abs(id[s[i]]-i);
}
}
printf("%lld\n",sum/2);
return 0;
}