POJ 1322 dp

Chocolate
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10605 Accepted: 2751 Special Judge

Description

In 2100, ACM chocolate will be one of the favorite foods in the world. 

"Green, orange, brown, red...", colorful sugar-coated shell maybe is the most attractive feature of ACM chocolate. How many colors have you ever seen? Nowadays, it's said that the ACM chooses from a palette of twenty-four colors to paint their delicious candy bits. 

One day, Sandy played a game on a big package of ACM chocolates which contains five colors (green, orange, brown, red and yellow). Each time he took one chocolate from the package and placed it on the table. If there were two chocolates of the same color on the table, he ate both of them. He found a quite interesting thing that in most of the time there were always 2 or 3 chocolates on the table. 

Now, here comes the problem, if there are C colors of ACM chocolates in the package (colors are distributed evenly), after N chocolates are taken from the package, what's the probability that there is exactly M chocolates on the table? Would you please write a program to figure it out? 

Input

The input file for this problem contains several test cases, one per line. 

For each case, there are three non-negative integers: C (C <= 100), N and M (N, M <= 1000000). 

The input is terminated by a line containing a single zero. 

Output

The output should be one real number per line, shows the probability for each case, round to three decimal places.

Sample Input

5 100 2

0

Sample Output

0.625 
 
题意:给你c种巧克力,每种巧克力是无限的,你可以任意选一种巧克力放到桌子上,当拿第i个巧克力的时候发现桌子上有这种
巧克力,就把两个巧克力都吃了,如果桌子上没有,则放到桌上,问拿了n次之后,桌子上剩m种巧克力的概率。
 
思路:dp,dp[i]【j】表示在拿了i次之后桌子上剩j种巧克力的概率。
方程:dp[i][j]=dp[i-1][j-1]*(c-(j-1.0))/c+dp[i-1][j+1]*(j+1.0)/c;
             //这里是表示拿了之后桌子上没有该种巧克力  //后半部分方程式拿了之后发现有该种巧克力,所以将两个都吃了
发现n比较大但是第i次的状态只和第i-1次有关系,所以可以使用滚动数组。
double dp[2][105];
 
下面贴上代码
 
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define N 1000005

using namespace std;

double dp[2][105];

int main()
{
	int i,j;
	int c,n,m;
	while(~scanf("%d",&c),c>0)
	{
		memset(dp,0,sizeof(dp));
		scanf("%d %d",&n,&m);
		if(m>c||m>n||(m+n)%2)
		{
			printf("0.000\n");
			continue;
		}
		dp[0][0]=dp[1][1]=1.0;
		if(n > 1000) n = 1000 - (n%2);//精确度不需要那么高 
		for(i=2;i<=n;i++)
		{
			dp[i%2][0] = dp[(i+1)%2][1] / c;
            dp[i%2][c] = dp[(i+1)%2][c-1] / c;
			for(j=1;j<=i&&j<c;j++)
			{
				dp[i%2][j]=dp[(i-1)%2][j-1]*(c-(j-1.0))/c+dp[(i-1)%2][j+1]*(j+1.0)/c;
			}
		}
		printf("%.3f\n",dp[n%2][m]);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值