HDU 5676 ztr loves lucky numbers

ztr loves lucky numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1992    Accepted Submission(s): 776


Problem Description
ztr loves lucky numbers. Everybody knows that positive integers are lucky if their decimal representation doesn't contain digits other than 4 and 7. For example, numbers 47, 744, 4 are lucky and 5, 17, 467 are not.

Lucky number is super lucky if it's decimal representation contains equal amount of digits 4 and 7. For example, numbers 47, 7744, 474477 are super lucky and 4, 744, 467 are not.

One day ztr came across a positive integer n. Help him to find the least super lucky number which is not less than n.
 

Input
There are T (1n105)  cases

For each cases:

The only line contains a positive integer  n(1n1018) . This number doesn't have leading zeroes.
 

Output
For each cases
Output the answer
 

Sample Input
  
  
2 4500 47
 

Sample Output
  
  
4747 47
题意: 幸运数是只含有4和7的数字,最幸运的数字是只含有4和7的数字并且4的数量和7的数量相等。给你一个数,让你求比它大的最小的幸运数。
思路: 因为只含有最幸运数只含有4和7并且4和7的数量相等,所以就算最大为10的18次方,总共的最幸运数也是可以数的过来的,所以,可以用打表的方式打出所有的幸运数,然后再寻找就可以。注意特判情况。
代码1:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>

using namespace std;

long long a[500000];
int cnt;

void dfs(int left,int right,long long num)
{
	if(left==0&&right==0)
	{
		a[++cnt]=num;
		return ;
	}
	if(left>0)
	{
		dfs(left-1,right,num*10+4);
	}
	if(right>0)
	{
		dfs(left,right-1,num*10+7);
	}
}

int main()
{
	int i,j;
	long long x;
	cnt=0;
	for(i=2;i<=18;i+=2)
	{
		dfs(i/2,i/2,0);
	}
	//printf("%d\n",cnt);
	/*for(i=1;i<=100;i++)
	{
		printf("%lld\n",a[i]);
	}*/
	sort(a+1,a+cnt+1);
	int n;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%lld",&x);
		if(x>777777777444444444){
            cout<<"44444444447777777777"<<endl;
            continue;
        }
		for(i=1;i<=cnt;i++)
		{
			if(a[i]>=x)
			{
				x=a[i];
				break;
			}
		}
		printf("%lld\n",x);
	}
	
	return 0;
}


代码2: (用了 二分查找 )

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>

using namespace std;

long long a[500000];
int cnt;

void dfs(int left,int right,long long num)
{
	if(left==0&&right==0)
	{
		a[++cnt]=num;
		return ;
	}
	if(left>0)
	{
		dfs(left-1,right,num*10+4);
	}
	if(right>0)
	{
		dfs(left,right-1,num*10+7);
	}
}

int main()
{
	int i,j;
	long long x;
	cnt=0;
	for(i=2;i<=18;i+=2)
	{
		dfs(i/2,i/2,0);
	}
	//printf("%d\n",cnt);
	/*for(i=1;i<=100;i++)
	{
		printf("%lld\n",a[i]);
	}*/
	sort(a+1,a+cnt+1);
	int n;
	scanf("%d",&n);
	long long ans;
	while(n--)
	{
		scanf("%lld",&x);
		if(x>777777777444444444){
            cout<<"44444444447777777777"<<endl;
            continue;
        }
        int left,right,mid;
        left=1;
        right=cnt;
		while(left<=right)
		{
			mid=(left+right)>>1;
			if(a[mid]>=x)
			{
				ans=a[mid];
				right=mid-1;
			}
			else
			{
				left=mid+1;
			}
		}
		printf("%lld\n",ans);
	}
	
	return 0;
}



 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值