hdu ztr loves lucky numbers (暴搜)

ztr loves lucky numbers
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

ztr loves lucky numbers. Everybody knows that positive integers are lucky if their decimal representation doesn't contain digits other than 4 and 7. For example, numbers 47, 744, 4 are lucky and 5, 17, 467 are not. 

Lucky number is super lucky if it's decimal representation contains equal amount of digits 4 and 7. For example, numbers 47, 7744, 474477 are super lucky and 4, 744, 467 are not. 

One day ztr came across a positive integer n. Help him to find the least super lucky number which is not less than n. 

Input

There are T  cases 

For each cases: 

The only line contains a positive integer  . This number doesn't have leading zeroes. 

Output

For each cases 
Output the answer

Sample Input

2
4500
47

Sample Output

4747
47

注意会爆long long 就算开无符号也只是两倍也会爆


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef unsigned long long LL;
const int N = 100010;
LL num[N];
int k;


void dfs(int pos,int cnt1,int cnt2,LL sum)
{
    if(pos>=19)
        return ;
    if(cnt1==cnt2&&cnt1+cnt2)
            num[k++]=sum;
    dfs(pos+1,cnt1+1,cnt2,sum*10+4);
    dfs(pos+1,cnt1,cnt2+1,sum*10+7);
    return ;
}


int main()
{
    k=0;
    dfs(0,0,0,0);
    sort(num,num+k);
    int t;
    scanf("%d", &t);
    while(t--)
    {
        LL x;
        scanf("%I64u", &x);
        int pos = lower_bound(num,num+k,x)-num;
        if(pos==k)
            printf("44444444447777777777\n");
        else
            printf("%I64u\n",num[pos]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值