POJ 2566 Bound Found(尺取)

Bound Found
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 4771 Accepted: 1518 Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15
题意: 给你n个数  k个操作  每个操作有一个t 你的任务是找到一个连续的序列使得这个序列的和的绝对值和t的差 尽可能的小
并且输出这个绝对值和序列的左右端点。
 
思路: 尺取  选择尺取需要数据的单调性,这里a数组不能确定其是否单调,所以考虑其变形,,用sum记录从0到i的和 和他
得下边  ,然后尺取sum。
 
代码: 
 
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define N 100005
#define inf 0x3f3f3f3f

using namespace std;

pair< int ,int >sum[N];
int n;

void solve(int t)
{
	int i,j;
	int left,right,fin,temp;
	int ansl,ansr,anss;
	fin=inf;
	right=1;
	left=0;
	while(left<=n&&right<=n)
	{
		temp=sum[right].first-sum[left].first;
		if(abs(temp-t)<fin)
		{
			fin=abs(temp-t);
			ansr=sum[right].second;
			ansl=sum[left].second;
			anss=temp;
		}
		if(temp<t) right++;
		else if(temp>t) left++;
		else break;
		
		if(left==right) right++;
		
	}
	
	if(ansl>ansr){
		int tt=ansl;
		ansl=ansr;
		ansr=tt;
	}
	
	printf("%d %d %d\n",anss,ansl+1,ansr);
	return ;
}


int main()
{
	int k,t;
	int i,j;
	while(~scanf("%d %d",&n,&k))
	{
		if(n==0&k==0) break;
	sum[0] = make_pair(0, 0);
	for(i=1;i<=n;i++)
	{
		scanf("%d",&sum[i].first);
		sum[i].second=i;
		sum[i].first+=sum[i-1].first;
	}
	sort(sum,sum+n+1);
	
	//for(i=0;i<=n;i++) printf("%d %d\n",sum[i].first,sum[i].second);
	
	while(k--)
	{
		scanf("%d",&t);
		solve(t);
	}
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值