POJ 2229

Sumsets
Time Limit: 2000MS Memory Limit: 200000K
Total Submissions: 20111 Accepted: 7859

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7: 

1) 1+1+1+1+1+1+1 
2) 1+1+1+1+1+2 
3) 1+1+1+2+2 
4) 1+1+1+4 
5) 1+2+2+2 
6) 1+2+4 

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000). 

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6
 
题意: 给你一个数n 问你可以多少种 2的某次方 相加表示。
 
简单题: 写出前几个数就可以推出dp公式 分奇偶数。
 
代码: 
 
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define N 1000005
#define mod 1000000000

using namespace std;

long long dp[N];

void init()
{
	dp[1]=1;
	for(int i=2;i<N;i++)
	{
		if(i%2) dp[i]=dp[i-1]%mod;
		else dp[i]=(dp[i-1]+dp[i/2])%mod;
	}
	return ;
}

int main()
{
	int n;
	init();
	scanf("%d",&n);
	printf("%lld\n",dp[n]);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值