POJ 2456 Aggressive cows [二分] 《挑战程序设计竞赛》3.1

题目链接: POJ 2456 Aggressive cows

题目大意:

有N间牛舍,C头牛。
N间牛舍在一条直线上, 位置分别为 x1,x2,...xn ,把C头牛放进其中的C间牛舍,要最大化最近的两头牛之间的距离。

条件限制:
2N100000
2MN
0xi109

Input

  • Line 1: Two space-separated integers: N and C

  • Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

  • Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

题解:

用二分法来最大化最小值。

用函数 is_ok(int m) := 可以安排牛的位置使得最近的两头牛之间的距离大于等于m
然后用二分查找m的最大值。

代码:

#include <iostream>
#include <algorithm>
#define MAXN 100010
using namespace std;

typedef long long ll;
int N, C;
ll x[MAXN];

bool is_ok(int m) {
    int i = 0, cnt = 1;
    ll current = x[i];
    while (i < N && cnt < C) {
        for (; i < N; i++) {
            if (x[i] - current >= m) {
                current = x[i];
                cnt++;
                break;
            }
        }
    }
    if (cnt >= C) return true;
    else return false;
}

int solve() {
    ll l = 1, r = x[N-1] - x[0];
    while (l < r) {
        ll mid = (l+r+1)/2;
        if (is_ok(mid)) l = mid;
        else r = mid-1;
    }
    return l;
}

int main() {
    std::ios::sync_with_stdio(false);
    cin >> N >> C;
    for (int i = 0; i < N; i++)
        cin >> x[i];
    sort(x, x+N);

    cout << solve() << endl;

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值