01-复杂度2 Maximum Subsequence Sum (25 分)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4
#include <iostream>
using namespace std;
int main()
{
    int N,i;
    int sublen;
    int ThisSum, MaxSum, frontdata, enddata;
    cin>>N;
    int data[N];
    for(i = 0; i<N; i++)
    {
        cin>>data[i];
    }
    sublen = ThisSum = frontdata = enddata = 0;
    MaxSum = -1; //初始化应该注意啊啊啊!!!!
    for(i = 0; i < N; i++)
    {
        ThisSum += data[i];
        sublen ++;
        if(ThisSum > MaxSum)
        {
            MaxSum = ThisSum;
            enddata = data[i];
            frontdata = data[i - sublen + 1];
        }
        if(ThisSum < 0)
        {
            ThisSum = 0;
            sublen = 0;
        }
    }
    if(MaxSum < 0)
    {
        cout<<0<<" "<<data[0]<<" "<<data[N-1]<<endl;
    }
    else
    {
        cout<<MaxSum<<" "<<frontdata<<" "<<enddata<<endl;
    }
    return 0;
}

哇,这下就好啦,你还得记录哦,那就用个enddata记录子序列最后一个,sublen记录这个子序列长度,那么子序列第一个元素frontdata 就是子序列最后的下标减去长度+1咯,可是可是,其实完全可以一个frontindex, 一个endindex来记录啊,好像更简单一点。。。。

还有啊,这个负数和真是令人头大,我一直通不过的一个是什么负数和0????那是是那么鬼 啊,后来把maxsum初始为-1就好了,虽然还是不知道为哈??

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值