HDOJ:1576-A/B(逆元模板)

A/B

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9926 Accepted Submission(s): 7965

Problem Description

要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。

Input

数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。

Output

对应每组数据输出(A/B)%9973。

Sample Input

2
1000 53
87 123456789

Sample Output

7922
6060

解题心得:

  1. 这是一个求逆元的模板题,如果需要得到(A/B)%C,当A和B特别大的时候必须先将A或B%C然后最后得到的结果就要处理一下。这里主要就是贴一下模板。
  2. 逆元的原理参考大佬的博客:https://www.cnblogs.com/Judge/p/9383034.html

第一种方法:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 100;
const int mod = 9973;

typedef long long ll;

int t;
ll a, b;

void exgcd(ll a, ll b, ll &x, ll &y) {
    if(b == 0) {
        x = 1, y = 0;
        return ;
    } else {
        exgcd(b, a%b, y, x);
        y -= (a/b)*x;
    }
}

int main() {
    //freopen("1.in", "r", stdin);
    scanf("%d",&t);
    while(t--) {
        scanf("%lld%lld",&a,&b);
        ll x, y;
        exgcd(b, mod, x, y);
        x *= a;
        x = (x%mod+mod)%mod;
        printf("%lld\n", x);
    }
    return 0;
}

第二种方法:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 100;
const int mod = 9973;

typedef long long ll;

int t;
ll a, b;

ll power_mod(ll x, ll cnt) {
    ll ans = 1;
    while(cnt) {
        if(cnt&1) ans *= x;
        x *= x;
        x %= mod;
        ans %= mod;
        cnt >>= 1;
    }
    return ans;
}

int main() {
    //freopen("1.in", "r", stdin);
    scanf("%d",&t);
    while(t--) {
        scanf("%lld%lld",&a,&b);
        ll ans = (a*power_mod(b, mod-2))%mod;
        printf("%lld\n", ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值