AC Me
Problem Description
Ignatius is doing his homework now. The teacher gives him some articles and asks him to tell how many times each letter appears.
It’s really easy, isn’t it? So come on and AC ME.
Input
Each article consists of just one line, and all the letters are in lowercase. You just have to count the number of each letter, so do not pay attention to other characters. The length of article is at most 100000. Process to the end of file.
Note: the problem has multi-cases, and you may use “while(gets(buf)){…}” to process to the end of file.
Output
For each article, you have to tell how many times each letter appears. The output format is like “X:N”.
Output a blank line after each test case. More details in sample output.
Sample Input
hello, this is my first acm contest!
work hard for hdu acm.
Sample Output
a:1
b:0
c:2
d:0
e:2
f:1
g:0
h:2
i:3
j:0
k:0
l:2
m:2
n:1
o:2
p:0
q:0
r:1
s:4
t:4
u:0
v:0
w:0
x:0
y:1
z:0
a:2
b:0
c:1
d:2
e:0
f:1
g:0
h:2
i:0
j:0
k:1
l:0
m:1
n:0
o:2
p:0
q:0
r:3
s:0
t:0
u:1
v:0
w:1
x:0
y:0
z:0
题是大水题,想说的是如何输入空格,自己用的一般是getline(cin,string),还有一种方法是gets(char*);记得第一次碰到这种题想了半天怎么去掉空格,应该是天梯赛的时候
AC代码:
#include<bits/stdc++.h>
using namespace std;
using LL =int64_t;
int main()
{
ios::sync_with_stdio(0);
cin.tie(0);
string temp;
while(getline(cin,temp)) {
int ans[30]={0};
for(int i=0;i<temp.length();i++) {
if(temp[i]-'a'>=0&&temp[i]-'a'<=25) {
ans[temp[i]-'a']++;
}
}
for(int i=0;i<26;i++)
cout<<char(i+'a')<<":"<<ans[i]<<endl;
cout<<endl;
}
return 0;
}