Hdu 2062 Subset sequence

Subset sequence

Problem Description
Consider the aggregate An= { 1, 2, …, n }. For example, A1={1}, A3={1,2,3}. A subset sequence is defined as a array of a non-empty subset. Sort all the subset sequece of An in lexicography order. Your task is to find the m-th one.

Input
The input contains several test cases. Each test case consists of two numbers n and m ( 0< n<= 20, 0< m<= the total number of the subset sequence of An ).

Output
For each test case, you should output the m-th subset sequence of An in one line.

Sample Input
1 1
2 1
2 2
2 3
2 4
3 10

Sample Output
1
1
1 2
2
2 1
2 3 1
这道题就是问你用n个数组成的子集中按字典序排序第m个是多少,这感觉是一道递归题,不断求子集的子集的问题…然而我看了好多网上的答案都不明所以,大概懂了点写了个代码,还得再看看…

#include<bits/stdc++.h>
using namespace std;
using LL =int64_t;

int main()
{
    ios::sync_with_stdio(0);
    cin.tie(0);
    LL num[25]={0,1},m;
    vector<int>cnt;
    for(int i=2;i<=20;i++) num[i]=(num[i-1]+1)*i;
    int n;
    while(cin>>n>>m) {
        cnt.clear();
        for(int i=1;i<=20;i++) cnt.push_back(i);
        while(n--){
            int k=(m-1)/(num[n]+1);
            cout<<cnt[k];
            cnt.erase(cnt.begin()+k);
            m=(m-1)%(num[n]+1);
            if(m==0) break;
            else cout<<" ";
        }
        cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值