hdu 2132

An easy problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6188    Accepted Submission(s): 1680


Problem Description
We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
Now there is a very easy problem . I think you can AC it.
  We can define sum(n) as follow:
  if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
  Is it very easy ? Please begin to program to AC it..-_-
 

Input
  The input file contains multilple cases.
  Every cases contain only ont line, every line contains a integer n (n<=100000).
  when n is a negative indicate the end of file.
 

Output
  output the result sum(n).
 

Sample Input
  
  
1 2 3 -1
 

Sample Output
  
  
1 3 30
 

Author
Wendell
 

Source
 

Recommend

威士忌

 

//注意输入0也是可以的。
#include<stdio.h>
int main()
{
	__int64 i, a[100001] = {0};
	for(i = 1; i <= 100000; i++)
		if(i % 3 == 0)
			a[i] = a[i-1] + i*i*i;
		else
			a[i] = a[i-1] + i;
	while(~scanf("%I64d", &i), i >= 0)
		printf("%I64d\n", a[i]);
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值