1028. List Sorting (25)

题目如下:

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
这一题不是很难,就是纯粹的排序,写几个cmp函数就可以了,用C库的快排函数Qsort()会比较好,因为最后一个case的n应该比较大,自己写的简单排序可能会超过时间界限。


代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

#define PRINT_I(x) printf("%s = %d\n",#x,x);
#define PRINT_F(x) printf("%s = %f\n",#x,x);
#define PRINT_S(x) printf("%s = %s\n",#x,x);

typedef struct student
{
	char id[8];
	char name[10];
	int grade;
}Stu;

int cmp1(const void *a,const void *b);
int cmp2(const void *a,const void *b);
int cmp3(const void *a,const void *b);

int main(int argc,char* argv[])
{
	Stu *stu;
	int i,n,c;

	//freopen("input","r",stdin);
	scanf("%d%d",&n,&c);

	stu = (Stu *)malloc(sizeof(Stu)*n);
	for(i=0;i<n;++i)
		scanf("%s%s%d",stu[i].id,stu[i].name,&stu[i].grade);

	switch(c)
	{
		case 1:
			qsort(stu,n,sizeof(Stu),cmp1);
			break;
		case 2:
			qsort(stu,n,sizeof(Stu),cmp2);
			break;
		case 3:
			qsort(stu,n,sizeof(Stu),cmp3);
			break;
	}

	for(i=0;i<n;i++)
		printf("%s %s %d\n",stu[i].id,stu[i].name,stu[i].grade);

	free(stu);
	return 0;
}

int cmp1(const void *a,const void *b)
{
	return strcmp((*(Stu *)a).id,(*(Stu *)b).id);
}
int cmp2(const void *a,const void *b)
{
	Stu *s1 = (Stu *)a;
	Stu *s2 = (Stu *)b;
	int i = strcmp(s1->name,s2->name);
	if( i )
		return i;
	else
		return strcmp(s1->id,s2->id);
}
int cmp3(const void *a,const void *b)
{
	Stu *s1 = (Stu *)a;
	Stu *s2 = (Stu *)b;

	if(s1->grade != s2->grade)
		return s1->grade - s2->grade;
	else
		return strcmp(s1->id,s2->id);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值