1010. Radix (25)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible
思路

题目给定N1、N2两个数字,tag是1的话,说明radix是N1的进制数,否则N2的进制数,要求找到让两个数字相等的进制。

写一个convert 函数将数字转化为10进制,以便计算。

再写一个find_radix函数利用二分法,寻找让N1、N2相等的进制

C++:

#include "cstdio"
#include "cctype"
#include "algorithm"
#include "cmath"
#include "string"
#include "iostream"

using namespace std;

//转化为十进制
long long convert(string n,long long radix){
	long long sum=0;
	int index=0,temp=0;
	for(auto it =n.rbegin();it!=n.rend();it++){
		temp=isdigit((*it))?*it-'0':*it-'a'+10;//从末尾开始计算 每一位的值
		sum+=temp*pow(radix,index++);//每一位乘以基数对应的次方 转化为十进制
	}
	return sum;
}

//寻找令两个数相等的进制
long long find_radix(string n,long long num){
	char it=*max_element(n.begin(),n.end());//取出最大的一位数字
	//二分法
	long long low=(isdigit(it)?it-'0':it-'a'+10)+1;
	long long high=max(num,low);
	while (low<=high)
	{
		long long mid=(low+high)/2;
		long long t=convert(n,mid);
		if(t<0||t>num)high=mid-1;//当t比num大 说明当前进制太大
		else if (t==num)return mid;
		else low=mid+1;
	}
	return -1;
}

int main(){
	string  n1,n2;
	long long tag=0,radix=0,result_radix;
	cin>>n1>>n2>>tag>>radix;
	result_radix=tag==1?find_radix(n2,convert(n1,radix)):find_radix(n1,convert(n2,radix));//相当于找一个数在什么进制下等于另一个数的十进制
	if(result_radix!=-1){
		printf("%lld",result_radix);
	}else{
		printf("Impossible");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值