1125 Chain the Ropes(25 分)

本文介绍了一种算法,用于解决如何将多段不同长度的绳子通过折叠和串连的方式组合成尽可能长的单一绳子的问题。该算法首先将所有绳子长度进行排序,然后依次选取最短的两段绳子进行串连,每次串连后绳子的长度减半,直至所有绳子都被串连起来。
摘要由CSDN通过智能技术生成

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10​4​​). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10​4​​.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

思路:

给定一段一段的绳子,你需要把它们串成一条绳。每次串连的时候,是把两段绳子对折,再如下图所示套接在一起。这样得到的绳子又被当成是另一段绳子,可以再次对折去跟另一段绳子串连。每次串连后,原来两段绳子的长度就会减半。给定N段绳子的长度,你需要找出它们能串成的绳子的最大长度

C++:

#include "iostream"
#include "algorithm"
#include "vector"
using namespace std;
vector<int> accord;
int main(){
	int n;
	scanf("%d",&n);
	accord.resize(n);
	for (int i=0;i<n;i++)
		scanf("%d",&accord[i]);
	sort(accord.begin(),accord.end());
	int maxl=accord[0];
	for (int i=1;i<n;i++)
	{
		maxl=(maxl+accord[i])/2;
	}
	printf("%d\n",maxl);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值