1146 Topological Order(25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

思路:

给一个有向图,判断给定序列是否是拓扑序列

①记录每个点的弧尾、弧头

②入度为0的可以删除,每删除一个点,对应的弧尾点的入度-1

③即使不是拓扑序列,仍要把数据读完

④在副本数据上模拟拓扑序列,原始图像要保存

⑤数组赋值给vector : vector<Elemtype> a(arr,arr+n)//数组名,数组长度

C++:

#include "iostream"
#include "vector"
using namespace std;
int main(){
	int n,m;
	cin>>n>>m;
	vector<int> v[1010];//存储出度
	int r[1010]={0};//存储入度
	int star,fini;
	for (int i=0;i<m;i++)
	{
		cin>>star>>fini;
		v[star].push_back(fini);
		r[fini]++;
	}
	int k;
	cin>>k;
	vector<int> ans;
	int temp,flag;
	for (int i=0;i<k;i++)
	{
		flag=1;
		vector<int> tin(r, r+n+1);//将r赋值给tin
		for (int j=0;j<n;j++){
			cin>>temp;
			if(flag==1){
				if (tin[temp]!=0)
				{
					ans.push_back(i);
					flag=0;
				}else
				{
					for (int k=0;k<v[temp].size();k++){
						tin[v[temp][k]]--;//减掉入度
					}
				}
			}
		}
	}
	for (int i=0;i<ans.size();i++)
	{
		if (i!=0)cout<<" ";
		cout<<ans[i];
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值