POJ 3126 Prime Path(bfs)

题目链接:http://poj.org/problem?id=3126

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 

1033
1733
3733
3739
3779
8779
8179

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source

Northwestern Europe 2006

题目题意:给你两个素数a,b,问你a变到b需要几步,一步只能变一个数字,并且改变以后的数也是素数。

题解:用广搜,广搜结果就是最短的。

学习此题的出处:http://blog.csdn.net/wangjian8006

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
const int maxn=1e5+7;
int prime[maxn];
void init()//素数筛法大表,只需要考虑大于1000的,小于1000的素数都不考虑。
{
    for(int i=2;i*i<maxn;i++)
    {
        for(int j=2*i;j<maxn;j+=i)
        {
            prime[j]=1;
            if(j<1000)
                prime[j]=1;
        }
        if(i<1000)
            prime[i]=1;
    }
}
int bfs(int first,int last)
{
    int dis[maxn];
    queue<int>q;
    int count[maxn];
    int vtemp,t[20];
    int temp,v;
    memset(dis,0,sizeof(dis));
    memset(count,0,sizeof(count));
    q.push(first);
    dis[first]=1;
    while(!q.empty())
    {
        v=q.front();
        q.pop();
        t[0]=v/1000;//将数字各位保存。
        t[1]=v%1000/100;
        t[2]=v%100/10;
        t[3]=v%10;
        for(int i=0;i<4;i++)//遍历修改素数各个位子上的数。
        {
            temp=t[i];
            for(int j=0;j<10;j++)
            {
                if(j!=temp)//改变的数和原来的不能相同。
                {
                t[i]=j;
                vtemp=t[0]*1000+t[1]*100+t[2]*10+t[3];//改变后的数vtemp;
                if(!dis[vtemp]&&!prime[vtemp])//dis用来判断是否出现过。
                {
                    count[vtemp]=count[v]+1;//count计算步数。
                    dis[vtemp]=1;
                    q.push(vtemp);
                }
                if(vtemp==last)
                    return count[vtemp];
                }
            }
            t[i]=temp;
        }
        if(v==last)
            return count[v];
    }
    return -1;
}
int main()
{
    int t;
    int n,m;
    int k;
    init();
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        k=bfs(n,m);
        if(k>=0)
            cout<<k<<endl;
        else
            cout<<"Impossible"<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值