HDU 5441 Travel (带权并查集 + 离线操作)

Travel

Problem Description
Jack likes to travel around the world, but he doesn’t like to wait. Now, he is traveling in the Undirected Kingdom. There are n cities and m bidirectional roads connecting the cities. Jack hates waiting too long on the bus, but he can rest at every city. Jack can only stand staying on the bus for a limited time and will go berserk after that. Assuming you know the time it takes to go from one city to another and that the time Jack can stand staying on a bus is x minutes, how many pairs of city (a,b) are there that Jack can travel from city a to b without going berserk?
 

Input
The first line contains one integer T,T5 , which represents the number of test case.

For each test case, the first line consists of three integers n,m and q where n20000,m100000,q5000 . The Undirected Kingdom has n cities and m bidirectional roads, and there are q queries.

Each of the following m lines consists of three integers a,b and d where a,b{1,...,n} and d100000 . It takes Jack d minutes to travel from city a to city b and vice versa.

Then q lines follow. Each of them is a query consisting of an integer x where x is the time limit before Jack goes berserk.

 

Output
You should print q lines for each test case. Each of them contains one integer as the number of pair of cities (a,b) which Jack may travel from a to b within the time limit x .

Note that (a,b) and (b,a) are counted as different pairs and a and b must be different cities.
 

Sample Input
  
  
1 5 5 3 2 3 6334 1 5 15724 3 5 5705 4 3 12382 1 3 21726 6000 10000 13000
 

Sample Output
  
  
2 6 12
 
【思路分析】
   参照别人的思路写的。。。这类题一定要多加训练。

代码如下:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;

const int maxn = 2e4 + 50;
const int maxm = 1e5 + 50;
const int maxq = 5e3 + 50;
int n,m,q,sum;
int sets[maxn],ans[maxn],number[maxn];

struct Edge
{
    int u,v,w;
    Edge()
    {

    }
    Edge(int u,int v,int w) : u(u),v(v),w(w)
    {

    }
    bool operator < (const Edge &e) const
    {
        return w < e.w;
    }

}edge[maxm];
struct Query
{
    int val,index;
    bool operator < (const Query &q) const
    {
        return val < q.val;
    }
}query[maxq];

void init()
{
    sum = 0;
    scanf("%d %d %d",&n,&m,&q);
    for(int i = 1;i <= n;i++)
    {
        sets[i] = i;
        number[i] = 1;
    }
    for(int i = 1;i <= m;i++)
    {
        scanf("%d %d %d",&edge[i].u,&edge[i].v,&edge[i].w);
    }
    for(int i = 1;i <= q;i++)
    {
        scanf("%d",&query[i].val);
        query[i].index = i;
    }
    sort(edge + 1,edge + m + 1);
    sort(query + 1,query + q + 1);
}
int finding(int x)
{
    return sets[x] = (sets[x] == x ? x : finding(sets[x]));
}
void merging(int a,int b)
{
    int p1 = finding(a);
    int p2 = finding(b);
    if(p1 != p2)
    {
        int x = number[p1];
        int y = number[p2];
        sum -= x * (x - 1);//即x个结点两两之间边的权值满足条件的点对数
        sum -= y * (y - 1);
        sets[p1] = p2;
        number[p2] += number[p1];
        number[p1] = 0;//以上三步将集合a并入集合b
        sum += (number[p2]) * (number[p2] - 1);
    }
}
void solve()
{
    int num = 1;
    for(int i = 1;i <= q;i++)
    {
        while(num <= m && edge[num].w <= query[i].val)//权值不大于q值时进行合并
        {
            merging(edge[num].u,edge[num].v);
            num++;
        }
        ans[query[i].index] = sum;
    }
    for(int i = 1;i <= q;i++)
        printf("%d\n",ans[i]);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值