hdu4027(线段树)

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 23360    Accepted Submission(s): 5556

Problem Description

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input

The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10

1 2 3 4 5 6 7 8 9 10

5

0 1 10

1 1 10

1 1 5

0 5 8

1 4 8

Sample Output

Case #1:

19

7

6

 解析:基本的线段树点修改,区间查询

#include<bits/stdc++.h>
using namespace std;
 
#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}

const int maxn=100000+10;
int n;
int q;
struct node{
	int l,r;
	ll sum;
}t[maxn<<2];

void pushUp(int m)
{
	t[m].sum=t[m<<1].sum+t[m<<1|1].sum;
}
void bulid(int l,int r,int m)
{
	t[m].l=l;
	t[m].r=r;
	if(l==r)
	{
		scanf("%lld",&t[m].sum);
		
		return ;
	}
	int mid=l+r>>1;
	bulid(l,mid,m<<1);
	bulid(mid+1,r,m<<1|1);
	pushUp(m);
}
void update(int L,int R,int m)
{
	if(t[m].l==t[m].r)
	{
		t[m].sum=sqrt(t[m].sum);
		return ;
	}
	if(L>t[m].r||R<t[m].l)return ;
	
	//本题精髓,其实开方几次之后就是1,不用再开方了。
	if(L<=t[m].l&&R>=t[m].r&&t[m].sum==t[m].r-t[m].l+1) return;
	
	int mid=t[m].l+t[m].r>>1;
	if(L<=mid)update(L,R,m<<1);
	if(R>mid)update(L,R,m<<1|1);
	pushUp(m);
}
ll query(int L,int R,int m)
{
	if(L<=t[m].l&&t[m].r<=R)
	{
		return t[m].sum;
	}
	int mid=t[m].l+t[m].r>>1;
	ll ans=0;
	if(L<=mid)ans+=query(L,R,m<<1);
	if(R>mid)ans+=query(L,R,m<<1|1);
	return ans;
}
int main()
{
	int cas=1;
	while(~scanf("%d",&n))
	{
		bulid(1,n,1);
		scanf("%d",&q);
		printf("Case #%d:\n",cas++);
		while(q--)
		{
			int s,x,y;scanf("%d%d%d",&s,&x,&y);
			int xx=min(x,y);int yy=max(x,y);
			if(s==0)
			{
				update(xx,yy,1);
			}
			else printf("%lld\n",query(xx,yy,1));
		}
		puts("");
	}
	return 0;
}

 

评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值