hdu2612(bfs)

5 篇文章 0 订阅

Find a way

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24977    Accepted Submission(s): 8146

Problem Description

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input

The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4

Y.#@

....

.#..

@..M

4 4

Y.#@

....

.#..

@#.M

5 5

Y..@.

.#...

.#...

@..M.

#...#

Sample Output

66

88

66

题意:Y和M要在@点见面,求两者到这点的总的最短时间。

解析:求出Y到所有@点的距离。然后再求一次M到@点的距离。两者相加,取所有的最小就可以。

#include<bits/stdc++.h>
using namespace std;

#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}

const int maxn=2005;
char s[maxn][maxn];
int d[maxn][maxn];
int dx[4]={1,0,-1,0},dy[4]={0,1,0,-1};
int n,m,fx,fy,mx,my;
typedef pair<int,int> P;
struct node{
	int x,y,step;
}k[maxn];

void bfs(int x,int y)
{
	queue<P> q;
	for(int i=0; i<n; i++)
	{
		for(int j=0; j<m; j++)
			d[i][j]=inf;
	}
	q.push(P(x,y));
	d[x][y]=0;
	while(q.size())
	{
		int i;
		P p=q.front();q.pop();
		for(i=0; i<4; i++)
		{
			int nx=p.first+dx[i];
			int ny=p.second+dy[i];
			if(nx>=0&&nx<n&&ny>=0&&ny<m&&d[nx][ny]==inf&&s[nx][ny]!='#')
			{
				q.push(P(nx,ny));
				d[nx][ny]=d[p.first][p.second]+1;
			}
		}
		if(i!=4)break;
	}
	return ;
}
int main()
{
	while(~scanf("%d%d",&n,&m))
	{
		int cnt=0;
		for(int i=0; i<n; i++)scanf("%s",s[i]);
		for(int i=0; i<n; i++)
		{
			for(int j=0; j<m; j++)
			{
				if(s[i][j]=='Y')
				{
					fx=i;
					fy=j;
				}
				if(s[i][j]=='M')
				{
					mx=i;
					my=j;
				}
				if(s[i][j]=='@')
				{
					k[cnt].x=i;
					k[cnt].y=j;
					k[cnt++].step=0;
				}
			}
		}
		bfs(fx,fy);
		
		for(int i=0; i<cnt; i++)
		{
			k[i].step+=d[k[i].x][k[i].y];
		}
		bfs(mx,my);
		int minx=inf;
		for(int i=0; i<cnt; i++)
		{
			k[i].step+=d[k[i].x][k[i].y];
			minx=min(k[i].step,minx);
		}
		printf("%d\n",minx*11);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值