hdu1829(带权并查集)

A Bug's Life

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19940    Accepted Submission(s): 6374

Problem Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2

3 3

1 2

2 3

1 3

4 2

1 2

3 4

Sample Output

Scenario #1:

Suspicious bugs found!

 

Scenario #2:

No suspicious bugs found!

题意:有一群虫子,现在给你一些关系,判断这些关系有没有错

思路:向量种类并查集,下面讲一下向量的种类并查集

本题的各个集合的关心有两种0同性,1异性,怎么判断有错,

1.先判断他们是否在一个集合,即父亲是否相同,若父亲相同,用向量算的父亲之间的关系和之前的关心有矛盾没,有矛盾就是有错。

2.如果不在一个集合,就合并他们的父亲,用向量根据根节点的关心求出父亲的关心,然后合并。

这是并查集的重要的操作路径压缩,路径压缩的时候关心就要更新比如 1- 2 是异性 2 - 3 是异性 那么1,2,3在同一集合父亲都是1,压缩过后1和3就是同性

这就路径压缩时的关系更新,关键是怎么更新呢?

这里主要讲sum[fx]=(sum[x]+sum[y]+1)&1;有点像向量,向量加法首尾相接

è¿éåå¾çæè¿°

就像是向量,求向量fx----> fx;

#include<bits/stdc++.h>
using namespace std;
 
#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ll long long
#define ull unsigned long long
#define mem(a,b) memset(a,b,sizeof(a))
int gcd(int a,int b){return b?gcd(b,a%b):a;}

int n,m,f[2005],sum[2005];
int Find(int x)
{
	if(x==f[x])return x;
	int root=Find(f[x]);
	sum[x]=(sum[x]+sum[f[x]])&1;
	return f[x]=root;
}
int main()
{
	int T,cas=1;scanf("%d",&T);
	while(T--)
	{
		int flag=0;
		scanf("%d%d",&n,&m);
		for(int i=0; i<=n; i++)
		{
			f[i]=i;
			sum[i]=0;
		}
		while(m--)
		{
			int x,y;scanf("%d%d",&x,&y);
			int fx=Find(x);
			int fy=Find(y);
			if(fx==fy)
			{
				if(sum[x]==sum[y])
				flag=1;
			}
			else 
			{
				f[fx]=fy;
				sum[fx]=(sum[x]+sum[y]+1)&1;
			}
		}
		printf("Scenario #%d:\n",cas++);
		if(flag) printf("Suspicious bugs found!\n");
        else printf("No suspicious bugs found!\n");
        
		puts("");
	}
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值