1059 Prime Factors (25分)

题目

Given any positive integer N N N, you are supposed to find all of its prime factors, and write them in the format N = p 1 k 1 × p 2 k 2 × ⋯ p m k m N = {p_1}^{k_1}\times {p_2}^{k_2}\times\cdots {p_m}^{k_m} N=p1k1×p2k2×pmkm.

Input Specification:

Each input file contains one test case which gives a positive integer N N N in the range of long int.

Output Specification:

Factor N in the format N = p 1 k 1 × p 2 k 2 × ⋯ × p m k m N = {p_1}^{k_1}\times{p_2}^{k_2}\times\cdots\times{p_m}^{k_m} N=p1k1×p2k2××pmkm, where {p_i}'s are prime factors of N N N in increasing order, and the exponent k i k_i ki is the number of p i p_i pi – hence when there is only one p i p_i pi k i k_i ki is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

题目大意

输出一个数的所有质因子。

思路

求质数还是采用常规方法,只是判断的范围可以动态变化,有这样的规律,当前因子为k则计算下一个因子从k开始,并且定义一个临时变量tt等于已求出因子的乘积,那么判断的上限就是n/t

代码

#include <iostream>
#include <cstdio>
#include <map>
#include <cmath>
using namespace std;

bool isPrime(int x){
    for(int i=2; i<=sqrt(x); i++){
        if(x%i == 0)
            return false;
    }
    return true;
}

int main(){
    map<int,int> mp;
    int n;
    scanf("%d", &n);
    int cnt = 2, t = n;
    while(t > 1){
        for(int i=cnt; i<=t; i++){ // 上下限动态变化
            if(isPrime(i) && t%i == 0){
                t /= i;
                cnt = i;
                //printf("%d\n", i);
                map<int,int>::iterator it = mp.find(i);
                if(it != mp.end())
                    mp[i]++;
                else
                    mp[i] = 1;
                break;
            }
        }
    }
    printf("%d=", n);
    for(map<int,int>::iterator it=mp.begin(); it!=mp.end(); it++){
        if(it != mp.begin())
            printf("*");
        printf("%d", it->first);
        if(it->second > 1)
            printf("^%d", it->second);
    }
    if(mp.empty())
        printf("%d", n);
    printf("\n");
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值