HDOJ 题目1002A + B Problem II (大数)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 209712    Accepted Submission(s): 40343


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 题目大意:大数的加法
ac代码
#include<stdio.h>
#include<string.h>
int main()
{
	int cot=0,n;
	char a[1010],b[1010];
	scanf("%d",&n);
	while(n--)
	{
	
		int c[1100],len1,len2,i,j,k=0,max;
		getchar();
		scanf("%s %s",a,b);
		len1=strlen(a);
		len2=strlen(b);
		i=len1-1;
		j=len2-1;
		memset(c,0,sizeof(c));
		while(i>=0||j>=0)
		{
			if(i<0&&j>=0)
				c[k]+=b[j]-'0';
			else
				if(i>=0&&j<0)
					c[k]+=a[i]-'0';
				else
					c[k]+=(a[i]-'0')+(b[j]-'0');
				k++;
				c[k]=c[k-1]/10;
				c[k-1]%=10;
				if(c[k])
					max=k;
				else
					max=k-1;
				j--;
				i--;
		}
		printf("Case %d:\n",++cot);
		printf("%s + %s = ",a,b);
		for(j=max;j>=0;j--)
			printf("%d",c[j]);
		printf("\n");
		if(n)
			printf("\n");
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值