HDOJ 题目1325 Is It A Tree?(并查集)

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14228    Accepted Submission(s): 3178


Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
 

Sample Input
  
  
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output
  
  
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1856  1233  1102  1875  1863 
 


和小希的迷宫略不同的是这个是个有向的。。不知怎么这个数据通过不了,不过提交ac了,纪念一下,吧

ac代码

#include<stdio.h>
#define maxn 100000 + 6
int tree[maxn],bj[maxn];                      //数组e的元素值等于当前序号父级的序号,不一定是树的根
/*int find(int x)
{                                                            //找树根
    if(tree[x]==x)
        return x;
    else
        return find(tree[x]);
}*/
int find(int x)  
{  
    int r=x;  
    while(tree[r]!=r)  
        r=tree[r];  
    return r;  
}  

 
int main()
{
    int i,j,k;
    int t,n,m,t1;
    int x,y,num;
    int w=0;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        if(m<0&&n<0)// m,n都小于0的时候跳出
            break;
        t=1;
		t1=1;
        w++;
        if(!(m||n))
            printf("Case %d is a tree.\n",w);
        else
        {
            for(i=1;i<=maxn;i++)
            {
                tree[i]=i;
                bj[i]=0;
            }
            tree[n]=m;
            bj[m]=bj[n]=1;
            while(scanf("%d%d",&m,&n)!=EOF&&(m||n))
            {
                x=find(m);
                y=find(n);
               /* if(x==y)
                    t=1;                                             //判断是否是环
                else
                    tree[n]=m;                                       //即使存在元素更改了父级也不影响树的个数
                
				if(t)
					t1=1;*/
				if(x!=y)
					tree[n]=m;//注意这是n,m
				else
					t=0;
				if(t==0)
					t1=0;
				bj[m]=bj[n]=1;
            }
            if(!t1)
                printf("Case %d is not a tree.\n",w);
            else
            {
                num=0;
                for(i=1;i<=maxn;i++)
                {
                    if(bj[i]==1&&tree[i]==i)                      //统计树根个数,为1时才符合题意
                    {
                        num++;
                        if(num>1)
                            break;
                    }
                }
                if(num>1)
                    printf("Case %d is not a tree.\n",w);
                else
                    printf("Case %d is a tree.\n",w);
            }
        }
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值