Is It A Tree? (并查集)

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

题意:这道题跟 哈希的迷宫 是一类题,也是判断给的一颗的对应关系是否能形成一颗树。

思路:用并查集判断两个端点是否在同一个集合内。在同一个集合的话就说明已经形成了回路,不能成一棵树了。不过这道题的坑点是:给的端点可能是相同的,因此要加一个特判条件(a!=b)。

代码如下:

#include<cstdio>
#include<cstring>
#include<map>
#include<iostream>
using namespace std;
int f[100005];
int getf(int v)    //找祖宗
{
    if(f[v]==v)
        return v;
    return f[v]=getf(f[v]);
}
int main()
{
    int a,b,k=1;
    while(~scanf("%d%d",&a,&b)&&(a!=-1||b!=-1))
    {
        if(a==0&&b==0)  //空树
        {
            printf("Case %d is a tree.\n",k++);
            continue;
        }
        for(int i=1;i<=100005;i++)  //初始化
            f[i]=i;
        map<int,int>v;    //记录出现过的端点
        v[a]=v[b]=1;
        f[b]=a;
        int flag=0;
        if(a==b)     //两端点相同的时候就错了
            flag=1;
        while(scanf("%d%d",&a,&b))
        {
            if(a==0&&b==0)
                break;
            v[a]=v[b]=1;
            int t1=getf(a);
            int t2=getf(b);
            if(t1!=t2&&a!=b)  //两个端点不在同一个集合内,且两段点相同
                f[t2]=t1;
            else
                flag=1;
        }
        if(flag)
            printf("Case %d is not a tree.\n",k++);
        else
        {
            map<int,int>::iterator it;
            for(it=v.begin();it!=v.end();it++)  //遍历每一个端点,判断是不是只有一个祖宗
            {
                if(f[it->first]==(it->first))
                    flag++;
            }
            if(flag==1)
                printf("Case %d is a tree.\n",k++);
            else
                printf("Case %d is not a tree.\n",k++);
        }
    }
}

 

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值