HDOJ 题目1518 Square(dfs)

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8903    Accepted Submission(s): 2894


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
 

Source
 

Recommend
LL   |   We have carefully selected several similar problems for you:   1732  1401  1043  1226  1180 
 
ac代码
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int len,n;
int v[10010],a[10010];
int cmp(const void *a,const void *b)
{
	return *(int *)a-*(int *)b;
}
int dfs(int d,int i,int cot)
{
	int j;
	if(d==len)
	{
		i=0;
		d=0;
		cot++;
		if(cot==4)
			return 1;
	}
	for(j=i;j<n;j++)
	{
		//if(a[j]+d<=len&&dfs(a[j]+d,j+1))
		if(!v[j])
		{
			v[j]=1;
			if(a[j]+d<=len&&dfs(a[j]+d,j+1,cot))
				return 1;
			v[j]=0;
		}
	}
	return 0;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int i,sum=0;
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			sum+=a[i];
		}
		qsort(a,n,sizeof(a[0]),cmp);
		len=sum/4;
		if(len*4!=sum||len<a[n-1])
		{
			printf("no\n");
			continue;
		}
		memset(v,0,sizeof(v));
		if(dfs(0,0,0))
			printf("yes\n");
		else
			printf("no\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值