HDOJ 题目1317 XYZZY(spfa)

XYZZY

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2882    Accepted Submission(s): 769


Problem Description
It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable. 
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms. 

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time. 
 

Input
The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing: 

the energy value for room i 
the number of doorways leaving room i 
a list of the rooms that are reachable by the doorways leaving room i 
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case. 
 

Output
In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless". 
 

Sample Input
  
  
5 0 1 2 -60 1 3 -60 1 4 20 1 5 0 0 5 0 1 2 20 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 21 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 20 2 1 3 -60 1 4 -60 1 5 0 0 -1
 

Sample Output
  
  
hopeless hopeless winnable winnable
 

Source
 

Recommend
Eddy   |   We have carefully selected several similar problems for you:   1535  1245  1384  1531  1385 
 
ac代码
#include<stdio.h>
#include<string.h>
#define INF 0xfffffff
struct ss 
{
	int to;
	int w;
}e[100010];
int cot,pre[100010],next[100010],vis[100010],dis[100010],deg[100010],q[100010];
void add(int u,int v,int w)
{
	e[cot].to=v;
	e[cot].w=w;
	next[cot]=pre[u];
	pre[u]=cot++;
}
int min(int a,int b)
{
	if(a>b)
		return b;
	else
		return a;
}
int spfa(int s,int t,int n)
{
	int u,v,w,f,r,i;
	//f=r=0;
	memset(deg,0,sizeof(deg));
	memset(dis,0,sizeof(dis));
	memset(vis,0,sizeof(v));
	/*for(i=1;i<=n;i++)
	{
		dis[i]=INF;
	}*/
	q[0]=s;
	dis[s]=100;
	//vis[s]=1;
	for(f=0,r=1;f!=r;f=(f+1)%120)
	{
		u=q[f];
		vis[u]=0;
		for(i=pre[u];i!=-1;i=next[i])
		{
			v=e[i].to;
			w=e[i].w;
			if(dis[v]<min(INF,dis[u]+w))
			{
				dis[v]=min(INF,dis[u]+w);
				if(!vis[v])
				{
					vis[v]=1;
					q[r]=v;
					r=(r+1)%120;
					deg[v]++;
					if(deg[v]>=n)
						dis[v]=INF;
				}
			}
		}
	}
	return dis[t]>0;
}
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF,n!=-1)
	{
		int i,j,k,s=-1,t=-1,w,m,v;
		cot=0;
		memset(pre,-1,sizeof(pre));
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&w,&m);
			while(m--)
			{
				scanf("%d",&v);
				add(i,v,w);
			}
			if(!w)
			{
				if(s==-1)
					s=i;
				else
					t=i;
			}
		}
		if(!spfa(s,t,n))
			printf("hopeless\n");
		else
			printf("winnable\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值