POJ 题目2082 Terrible Sets(单调栈)

Terrible Sets
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 3702 Accepted: 1934

Description

Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0.
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑ 0<=j<=i-1wj <= x <= ∑ 0<=j<=iwj}
Again, define set S = {A| A = WH for some W , H ∈ R + and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}.
Your mission now. What is Max(S)?
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy.
But for this one, believe me, it's difficult.

Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w 1h 1+w 2h 2+...+w nh n < 10 9.

Output

Simply output Max(S) in a single line for each case.

Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1

Sample Output

12
14

Source

Shanghai 2004 Preliminary

http://www.cnblogs.com/lzmfywz/p/3253020.html

题目大意:给出一系列矩形的宽度和高度,矩形沿着x轴对齐,求这些矩形组成的连续矩形区域的最大面积。
解题方法:这是一道非常好的题,用栈保存矩形,如果高度递增则不断入栈,如果遇到当前输入的比栈顶高度小,则从栈顶开始不断出栈并且计算最大面积,直到栈顶高度小于当前输入高度则停止出栈,并把开始出栈矩形的宽度累加得到totalw,把totalw和当前输入的矩形宽度相加得到当前输入矩形的宽度,并入栈,这样栈中保存的永远都是高度递增的矩形,最后输入完了之后如果栈不为空,则依次出栈并计算最大面积。
ac代码

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<stack>
using namespace std;
struct s
{
	int w,h;
}a,temp;
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF,n!=-1)
	{
		int i;
		stack<struct s>st;
		int ans=0,w,h;
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&w,&h);
			if(st.empty())
			{
				temp.w=w;
				temp.h=h;
				st.push(temp);
			}
			else
			{
				a=st.top();
				if(h>=a.h)
				{
					temp.w=w;
					temp.h=h;
					st.push(temp);
				}
				else
				{
					int popw=0;
					while(!st.empty()&&a.h>h)
					{
					//	a=st.top();
						popw+=a.w;
						if(popw*a.h>ans)
							ans=popw*a.h;
						st.pop();
						if(!st.empty())
							a=st.top();
					}
					temp.w=w+popw;
					temp.h=h;
					st.push(temp);
				}
			}
		}
		int popw=0;
		while(!st.empty())
		{
			a=st.top();
			popw+=a.w;
			if(popw*a.h>ans)
				ans=popw*a.h;
			st.pop();
		}
		printf("%d\n",ans);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值