poj2082(单调栈)

Terrible Sets
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5256 Accepted: 2664

Description

Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0. 
Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑ 0<=j<=i-1wj <= x <= ∑ 0<=j<=iwj} 
Again, define set S = {A| A = WH for some W , H ∈ R + and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}. 
Your mission now. What is Max(S)? 
Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy. 
But for this one, believe me, it's difficult.

Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w 1h 1+w 2h 2+...+w nh n < 10 9.

Output

Simply output Max(S) in a single line for each case.

Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1

Sample Output

12

14

/*题意:紧贴x轴有一些互挨着的矩形,
给定每个矩形的长宽, 
问他们可以形成的最大矩形面积 */
#include<iostream>
#include<stack>
using namespace std;
#define MAXN 10005
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
typedef long long ll;

struct rec
{
	int w,h;//矩形宽和高
} data;

int main()
{
	int n;
	while(scanf("%d",&n)&&n!=-1)
	{
		int ans=0;
		stack<rec> s;
		int lasth=0,totalw,curarea;
		for(int i=0; i<n; i++)
		{
			scanf("%d%d",&data.w,&data.h);
			if(data.h>=lasth)
				s.push(data);
			else
			{
				totalw=0;
				curarea=0;
				while(!s.empty()&&s.top().h>data.h)
				{
					totalw+=s.top().w;
					curarea=totalw*s.top().h;
					if(curarea>ans)
						ans=curarea;
					s.pop();
				}
				totalw+=data.w;
				data.w=totalw;
				s.push(data);
			}
			lasth=data.h;
		}
		totalw=0;
		curarea=0;
		while(!s.empty())
		{
			totalw+=s.top().w;
			curarea=totalw*s.top().h;
			if(curarea>ans)
				ans=curarea;
			s.pop();
		}
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值