java回文串判定

Problem Description

输入一串字符(长度小于100),判断该串字符是否是回文串(正序读与逆序读内容相同)。

Input

输入一串字符(长度小于100)。

Output

若该串字符是回文串输出“yes",否则输出”no“。

Example Input
asdfgfdsa
Example Output
yes

import java.util.Scanner;
public class Main
{  
 public static void main(String[] args)
 { 
       Scanner reader=new Scanner(System.in);
       String str;
       str=reader.nextLine();
       char a[]=str.toCharArray();
       int i;
       int flag=1;
       for(i=str.length()-1;i>=0;i--)
       {
       if(a[i]==a[str.length()-1-i])
       {
        flag=1;
       }
       else
       {
        flag=0;
        break;
       }
       }
       if(flag==1)
       {
        System.out.println("yes");
       }
       else
       {
        System.out.println("no");
       }
 } 
 } 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值