hdu 1069 —— Monkey and Banana

Monkey and Banana

时间限制: 1000ms
内存限制: 32768KB
HDU       ID:  1069
64位整型:      Java 类名:

题目描述

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

输入

The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

输出

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

样例输入

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

样例输出

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

题目的意思是:

有n种长方体,每种长方体都有无限多个,问用这些长方体最高能摆多高?(也可以这样理解:类似于矩形嵌套,这题是方块嵌套,方块可以旋转,嵌套规则为前一个方块的长和宽都大于后面的长和宽,求这样嵌套下去后能得到的最大长度)

要求:下面的长方体的长大于上面长方体的长,宽大于上面长方体的宽;


题解:首先读取方块,一个方块可以变换为9种方块,然后按照长度排序,dp[i]表示以第i个方块结尾时得到的序列长度。


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[300];
struct node{
    int x,y,z;
};
node tmp[300];

bool cmp(node a,node b){
    return a.x>b.x;
}
int main()
{
    int n,k,kk=1;
    while(~scanf("%d",&n)){
        if(n==0)    break;
        int x1,y1,z1;
        k=0;
        for(int i=0;i<n;i++){
            scanf("%d%d%d",&x1,&y1,&z1);
            tmp[k].x=x1;    tmp[k].y=y1;    tmp[k++].z=z1;
            tmp[k].x=x1;    tmp[k].y=z1;    tmp[k++].z=y1;
            tmp[k].x=y1;    tmp[k].y=x1;    tmp[k++].z=z1;
            tmp[k].x=y1;    tmp[k].y=z1;    tmp[k++].z=x1;
            tmp[k].x=z1;    tmp[k].y=x1;    tmp[k++].z=y1;
            tmp[k].x=z1;    tmp[k].y=y1;    tmp[k++].z=x1;
        }
        sort(tmp,tmp+k,cmp);
        int ans;
        ans=dp[0]=tmp[0].z;
        for(int i=1;i<k;i++){
            dp[i]=tmp[i].z;
            for(int j=i-1;j>=0;j--){
                if(tmp[i].x < tmp[j].x && tmp[i].y < tmp[j].y)
                    dp[i]=max(dp[i],dp[j]+tmp[i].z);
            }
            ans=max(ans,dp[i]);
        }
        printf("Case %d: maximum height = %d\n",kk++,ans);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

黎轩栀海

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值