hdu1236排序水题

今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的
考生,并将他们的成绩按降序打印。
Input
测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;
以下N行,每行给出一
名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号
(题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理。
Output
对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考
号的升序输出。
Sample Input
4 5 25
10 10 12 13 15
CS004 3 5 1 3
CS003 5 2 4 1 3 5
CS002 2 1 2
CS001 3 2 3 5
1 2 40
10 30
CS001 1 2
2 3 20
10 10 10
CS000000000000000001 0
CS000000000000000002 2 1 2
0
Sample Output
3
CS003 60
CS001 37
CS004 37
0
1
CS000000000000000002 20

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <map>
#define N 1005
using namespace std;

typedef struct note {
	char name[25];
	int score;
}node;

node stu[N];
int f[12];

int cmp(node a, node b)
{
	if (a.score == b.score)
		return strcmp(a.name, b.name) < 0;
	else
		return a.score > b.score;
}

int main()
{
	int n, m, g;
	while (~scanf("%d", &n) && n)
	{
		int ans = 0;
		memset(stu, 0, sizeof(stu));
		scanf("%d%d", &m, &g);
		for (int i = 1; i <= m; i++)
			scanf("%d", &f[i]);
		getchar();
		int ss, t;

		for (int i = 1; i <= n; i++)
		{
			scanf("%s", &stu[i].name);
			scanf("%d", &ss);
			for (int j = 1; j <= ss; j++)
			{
				scanf("%d", &t);
				stu[i].score += f[t];
			}
			if (stu[i].score >= g)	ans++;
		}

		sort(stu + 1, stu + n + 1, cmp);

		printf("%d\n", ans);
		for (int i = 1; i <= n; i++)
		{
			if (stu[i].score >= g)
			{
				printf("%s", stu[i].name);
				printf(" %d\n", stu[i].score);
			}
			else
				break;
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值