2017ACM/ICPC广西邀请赛-重现赛 hdu 6186

 

Little A has come to college and majored in Computer and Science. 

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework. 

Here is the problem: 

You are giving n non-negative integers a1,a2,⋯,ana1,a2,⋯,an, and some queries. 

A query only contains a positive integer p, which means you 
are asked to answer the result of bit-operations (and, or, xor) of all the integers except apap. 

Input

There are no more than 15 test cases. 

Each test case begins with two positive integers n and p 
in a line, indicate the number of positive integers and the number of queries. 

2≤n,q≤1052≤n,q≤105 

Then n non-negative integers a1,a2,⋯,ana1,a2,⋯,an follows in a line, 0≤ai≤1090≤ai≤109 for each i in range[1,n]. 

After that there are q positive integers p1,p2,⋯,pqp1,p2,⋯,pqin q lines, 1≤pi≤n1≤pi≤n for each i in range[1,q].

Output

For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except apap in a line. 

Sample Input

3 3
1 1 1
1
2
3

Sample Output

1 1 0
1 1 0
1 1 0

分别对  &  |  ^  统计一下前缀后缀就行了

#include<bits/stdc++.h>
using namespace std;
typedef long long int ll;
//typedef unsiged long long ull;
const int maxn=1e5+5;
int pre1[maxn],pre2[maxn],pre3[maxn],sa1[maxn],sa2[maxn],sa3[maxn],a[maxn],n,q;
int main()
{
	
	while(~scanf("%d%d",&n,&q))
	{
		memset(a,0,sizeof a);
		
		for(int i=1;i<=n;i++)scanf("%d",&a[i]);
		pre1[1]=pre2[1]=pre3[1]=a[1];
		
		for(int i=2;i<=n;i++)
		{
			pre1[i]=a[i]&pre1[i-1];
			pre2[i]=a[i]|pre2[i-1];
			pre3[i]=a[i]^pre3[i-1];
		}
		sa1[n]=sa2[n]=sa3[n]=a[n];
		for(int i=n-1;i>=1;i--)
		{
			sa1[i]=a[i]&sa1[i+1];
			sa2[i]=a[i]|sa2[i+1];
			sa3[i]=a[i]^sa3[i+1];
		}
		while(q--)
		{
			int x;scanf("%d",&x);
			if(x==1)printf("%d %d %d\n",sa1[x+1],sa2[x+1],sa3[x+1]);
			else if(x==n)printf("%d %d %d\n",pre1[x-1],pre2[x-1],pre3[x-1]);
			else printf("%d %d %d\n",pre1[x-1]&sa1[x+1],pre2[x-1]|sa2[x+1],pre3[x-1]^sa3[x+1]);
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值