hdu 2199 2899 (二分,三分)

HDU2199   Can you solve this equation?

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 


 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 


 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 


 

Sample Input
  
  
2 100 -4
 


 

Sample Output
  
  
1.6152 No solution!

二分法:

#include<stdio.h>
#include<math.h>
double f(double x)
{
	return 8*pow(x,4.0)+7*pow(x,3.0)+2*pow(x,2.0)+3*x+6;
}
int main()
{
	int T;
	double y,l,r,m;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%lf",&y);
		if(f(0.0)<=y&&f(100.0)>=y)
		{
			l=0;
			r=100;
			while(r-l>=1e-6)
			{
				m=(r+l)/2;
				if(f(m)<y)
					l=m+1e-7;
				else
				    r=m-1e-7;
			}
			printf("%.4lf\n",(l+r)/2);
		}
		else 
		   printf("No solution!\n");
	}
	return 0;
}

 

 

HDU2899  Strange fuction

Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 


 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 


 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 


 

Sample Input
  
  
2 100 200
 


 

Sample Output
  
  
-74.4291 -178.8534
 


 

// 三分法 
#include<stdio.h>
#include<math.h>
double f(double x,double y)
{
	return 6*pow(x,7.0)+8*pow(x,6.0)+7*pow(x,3.0)+5*pow(x,2.0)-y*x;
}
int main()
{
	int T;
	double y,l,r,lt,rt,y1,y2;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%lf",&y);
		l=0.0;
		r=100.0;
		while(r-l>1e-6)
		{
			lt=(2*l+r)/3;
			rt=(l+2*r)/3;
			y1=f(lt,y);
			y2=f(rt,y);
			if(y1<y2)
			   r=rt;
			else
			   l=lt;
		}
		printf("%.4lf\n",f(r,y));
	}
	return 0;
}

//二分法 
#include<stdio.h>
#include<math.h>
double f(double x,double y)
{
	return 6*pow(x,7.0)+8*pow(x,6.0)+7*pow(x,3.0)+5*pow(x,2.0)-y*x;
}
double fd(double x)
{
	return 42*pow(x,6.0)+48*pow(x,5.0)+21*pow(x,2.0)+10*x;
}
int main()
{
	int T;
	double l,r,m,y;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%lf",&y);
		l=0.0;
		r=100.0;
		while(r-l>1e-6)
		{
			m=(l+r)/2;
			if(fd(m)-y<=0)
			   l=m;
			else
			   r=m;
		}
		printf("%.4lf\n",f((l+r)/2,y));
	}
	return 0;
}
			


 


 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值