杭电1002 A + B Problem II

37 篇文章 0 订阅
5 篇文章 0 订阅
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

//我以前也写过,这一次写出了新问题,可能你也会出现

#include<stdio.h>
#include<string.h>
#define max 1010
int main()
{
	int a[max],b[max];
	char s1[max],s2[max];
	int len1,len2,len,i,j;
	int t,k=0;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		scanf("%s %s",s1,s2);
		printf("Case %d:\n",++k);
		printf("%s + %s = ",s1,s2);
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		len1=strlen(s1);
		len2=strlen(s2);
		j=0;
		
		for(i=len1-1;i>=0;--i)
		{
			a[j++]=s1[i]-'0';
		}
		j=0;
		for(i=len2-1;i>=0;--i)
		{
			b[j++]=s2[i]-'0';
		}
		//len=len1>len2?len1:len2; 
		
		for(i=0;i<max;++i)//要写成max ,不能写成len ,因为相加会进位 
		{
			a[i]+=b[i];
			if(a[i]>=10)
			{
				a[i]-=10;
				a[i+1]++;
			}
		}
		for(i=max-1;i>0;--i)//这里i>0,0+0=0;不然没输出 
		{
			if(a[i]!=0) break;
		}
		
		for(j=i;j>=0;--j)
		{
			printf("%d",a[j]);
		}
		puts("");
		if(t) puts("");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值