Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
Output
For each test case,output the answer on a single line.
Sample Input
3 1 1 10 2 10000 72
Sample Output
1 6 260
题意:求1-N中有多少数X的GCD(N,X)>=M
#include <stdio.h>
#include <string.h>
int euler(int n)
{
int ans=n;
for(int i=2;i*i<=n;++i)
{
if(n%i==0)
ans=ans/i*(i-1);
while(n%i==0) n/=i;
}
if(n>1) ans=ans/n*(n-1);
return ans;
}
int main()
{
int T;
int N,M;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&N,&M);
int sum=0;
for(int i=1;i*i<=N;++i)
{
if(N%i==0)
{
if(i>=M)//N/i的质因子*i和N的最大公约数为i > M
sum+=euler(N/i);
if((N/i)>=M&&(N/i)!=i)//当i*i==N时,只需要算一次
sum+=euler(i);//N>=i*M
}
}
printf("%d\n",sum);
}
return 0;
}