GCD HDU杭电2588 【欧拉函数的应用】

20 篇文章 0 订阅
Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

Output
For each test case,output the answer on a single line.

Sample Input
  
  
3 1 1 10 2 10000 72

Sample Output
  
  
1 6 260


题意:求1-N中有多少数X的GCD(N,X)>=M

#include <stdio.h>
#include <string.h>
int euler(int n)
{
	int ans=n;
	for(int i=2;i*i<=n;++i)
	{
		if(n%i==0)
			ans=ans/i*(i-1);
		while(n%i==0) n/=i;		
	}
	if(n>1) ans=ans/n*(n-1);
	return ans;
}
int main()
{
	int T;
	int N,M;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&N,&M);
		int sum=0;
		for(int i=1;i*i<=N;++i)
		{
			if(N%i==0)
			{
				if(i>=M)//N/i的质因子*i和N的最大公约数为i > M 
					sum+=euler(N/i);
					
				if((N/i)>=M&&(N/i)!=i)//当i*i==N时,只需要算一次 
					sum+=euler(i);//N>=i*M 
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值