hdoj2588GCD【欧拉函数】

 


GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1331    Accepted Submission(s): 604


Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
      
      
3 1 1 10 2 10000 72
 

Sample Output
      
      
1 6 260
 


题意:求1~N中与N的最大公约数大于M的个数

设N=a*b,X=a*d;gcd(N,X)==a所以b和d互质因为X<=N所以d为小于等于b的任意数;所以d的数量即为b的欧拉函数值所以只需要枚举a求出b的欧拉函数值即可

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int Eular(int n){
	int ret=1,i;
	for(i=2;i*i<=n;i++){
		if(n%i==0){
			n/=i;ret*=i-1;
			while(n%i==0){
				n/=i;ret*=i;
			}
		}
	}
	if(n>1)
	ret*=n-1;
	return ret;
}
int main()
{
	int t,i,j,ans,N,M;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&N,&M);
		ans=0;
		for(i=1;i*i<=N;++i){
			if(N%i==0){
				if(i>=M)ans+=Eular(N/i);
				if(N/i>=M&&i*i!=N)ans+=Eular(i);
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值