Just a Numble HDU杭电2117

Problem Description
Now give you two integers n m, you just tell me the m-th number after radix point in 1/n,for example n=4,the first numble after point is 2,the second is 5,and all 0 followed

Input
Each line of input will contain a pair of integers for n and m(1<=n<=10^7,1<=m<=10^5)

Output
For each line of input, your program should print a numble on a line,according to the above rules

Sample Input
  
  
4 2 5 7 123 123

Sample Output
  
  
5 0 8


//模拟除法运算 
#include <stdio.h>
int main()
{
	int m,n;
	while(~scanf("%d%d",&n,&m))
	{
		if(n==1)
		{
			printf("0\n");
			continue;
		} 
		int t=10;//为什么从10开始,因为题目要求的是小数点后m位的数 
		int res;
		while(m--)
		{
			res=t/n;
			t=t%n*10;
		}
		printf("%d\n",res);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值