HDU杭电5630 ( Rikka with Chess )

20 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=5630

Rikka with Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 516    Accepted Submission(s): 430


Problem Description
Yuta gives Rikka a chess board of size n×m .

As we all know, on a chess board, every cell is either black or white and every two cells that share a side have different colors.

Rikka can choose any rectangle formed by board squares and perform an inversion, every white cell becomes black, and vice versa.

Rikka wants to turn all cells into the same color, please tell Rikka the minimal number of inversions she need to achieve her goal.
 

Input
The first line contains a number T(T10) ——The number of the testcases.

Each testcase contains two numbers n,m(n109,m109) .
 

Output
For each testcase, print a single number which represents the answer.
 

Sample Input
  
  
3 1 2 2 2 3 3
 

Sample Output
  
  
1 2 2
 
题意:棋盘上是黑白交替的棋子,对某行或者某列处理,问最少多少次能把棋盘上的元素变成一种颜色
举个例子吧:
4*4的棋盘,你先对第二行第四行处理,然后对第二列第四列处理,你会发现解决了,就是这个规律,自己可以试试,这里不方面画图

#include <cstdio>
#include <cstring>
#include <algorithm>
#define max(a,b) (a>b?a:b)
#define min(a,b) (a<b?a:b)
int main()
{
    int T;
    int n,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        if(n<m)
        {
            int temp=n;
            n=m;m=temp;
        }
        if(m==1)
        {
            printf("%d\n",n/2);
            continue;
        }
        printf("%d\n",n/2+m/2);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值