hdu5630(规律)

43 篇文章 0 订阅

Rikka with Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 535    Accepted Submission(s): 444


Problem Description
Yuta gives Rikka a chess board of size  n×m .

As we all know, on a chess board, every cell is either black or white and every two cells that share a side have different colors.

Rikka can choose any rectangle formed by board squares and perform an inversion, every white cell becomes black, and vice versa.

Rikka wants to turn all cells into the same color, please tell Rikka the minimal number of inversions she need to achieve her goal.
 

Input
The first line contains a number  T(T10)  ——The number of the testcases.

Each testcase contains two numbers  n,m(n109,m109) .
 

Output
For each testcase, print a single number which represents the answer.
 

Sample Input
  
  
3 1 2 2 2 3 3
 

Sample Output
  
  
1 2 2
 
题目大意:有一个n*m的黑白相间的棋盘,现在可以选择棋盘中任意的矩形将其颜色反转。问最少需要多少步才能使整个棋盘的颜色相同?
解题思路:通过1x1,2x2,3x3,4x4的棋盘情况可以发现每行的黑白情况交替出现,当经过n/2次变换后(每隔一行反转一次,所以需要n/2次)所有行都相同。
因此此时只需在变换m/2次就可以将所有格子变成一种颜色。
ac代码:
#include<stdio.h>
#include<string.h>
int main()
{
	int t,n,m,x,y,num;
	scanf("%d",&t);
	while(t--)
	{
		num=0;
		scanf("%d%d",&n,&m);
		num+=(n/2+m/2);
		printf("%d\n",num);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值