HDU 1220 ( Cube )

20 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=1220

Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1737    Accepted Submission(s): 1382


Problem Description
Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.
 

Input
There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).
 

Output
For each test case, you should output the number of pairs that was described above in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
0 16 297
Hint
Hint
The results will not exceed int type.
 

题意:
对于N*N*N的立方体,问有几对no more than two common points(不超过两个公共点),我们只需要找到所有4个公共点的对数,即相邻就有四个公共点

自己的思路:把一个立体剖分成多个部分,并算出每个部分有多少块



#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <iostream>
#define Max(a,b) (a>b?a:b)
#define Min(a,b) (a<b?a:b)
using namespace std;
int main()
{
    int N;
    while(~scanf("%d",&N))
    {
        int a,b,c,d,e,f;
        int temp=N*N*N;
        int sum=temp*(temp-1)/2;
        if(N==1) 
        {
            printf("0\n");
            continue;
        }
        if(N==2) 
        {
            printf("16\n");
            continue;
        }
        a=8*3/2;//3个 
        b=(N-2)*12*2;//4个 
        c=(N-2)*(N-2)*6*5/2;//5个 
        d=(N-2)*(N-2)*(N-2)*6/2;//6个 
        printf("%d\n",sum-a-b-c-d); 
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值