甲级 1001 A+B Format

本文介绍了一个C++程序,用于计算两个整数a和b的和,并将结果转换为标准格式,即每三位数字用逗号分隔。代码中使用了向量和字符串操作来实现这一功能。
摘要由CSDN通过智能技术生成

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 下面是我的代码:

#include <bits/stdc++.h>
using namespace std;
int main()
{
    int a,b;
    cin >> a >> b;
    int sum = a+b;
    if (sum < 0) {
        cout << "-";            //先输出符号,后续只处理非负数
        sum = -sum;
    }
    vector <char> v;
    string s = to_string(sum);            //添加‘,’  把数字转化成字符串
    int cnt = 0;
    for (int i = s.size()-1; i >= 0; i--) {
        cnt++;
        v.push_back(s[i]);                //cnt计数,满三个数字就加一个‘,’  最后一个数字需要存进去用于输出,但不需要处理‘,’
        if (cnt == 3 && i > 0) {
            v.push_back(',');
            cnt = 0;
        }
    }
    for (int i = v.size()-1; i >= 0; i--) {
        cout << v[i];            //输出
    }
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值