UVA-10943 How do you add?

Larry is very bad at math — he usually uses a calculator, which worked well throughout college. Unforunately, he is now struck in a deserted island with his good buddy Ryan after a snowboarding accident.
They’re now trying to spend some time figuring out some good problems, and Ryan will eat Larry if he cannot answer, so his fate is up to you!
It’s a very simple problem — given a number N, how many ways can K numbers less than N add up to N?
For example, for N = 20 and K = 2, there are 21 ways:
0+20
1+19
2+18
3+17
4+16
5+15

18+2
19+1
20+0
Input
Each line will contain a pair of numbers N and K. N and K will both be an integer from 1 to 100, inclusive. The input will terminate on 2 0’s.

Output
Since Larry is only interested in the last few digits of the answer, for each pair of numbers N and K, print a single number mod 1,000,000 on a single line.

Sample Input
20 2
20 2
0 0

Sample Output
21
21

分析:使用排列组合中的隔板法,在n个相同元素的队列中,插入k-1个板,使队列分成k个非空部分,和为n。若要去除非空这个条件,则在队列中加入k个元素(代表空集),则得到C(n-1+k,k-1)。接下来用动态规划求杨辉三角即可。

Source:

#include<stdio.h>
int main()
{
    int n,k,i,j;
    int d[200][200];
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        if(n==0&&k==0)
            return 0;
        for(i=0;i<=n+k-1;i++)
        {
            for(j=0;j<=i;j++)
            {
                if(j==0||i==j)
                    d[i][j]=1;
                else
                    d[i][j]=(d[i-1][j-1]+d[i-1][j])%1000000;
            }
        }
        printf("%d\n",d[n+k-1][k-1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值